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About "StitchBuddy"

Introducing embroidery on Macs for hobbyists.

Viewing embroideries

View embroidery designs, zoom, copy, print and

preview color changes.

Modifying embroideries

Rotate and flip embroidery designs, convert

them into other formats and save your changes.

Purchasing "StitchBuddy"

Purchase StitchBuddy via PayPal.

FEATURED TOPICS

Change thread colors

Convert a design

Obtain and enter a license code
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About "StitchBuddy"

StitchBuddy is a hobby-oriented application to view and modify embroidery designs

directly on your Macintosh.

Do you own an embroidery machine and a Mac? Maybe you want to modify your

embroideries, change their colors, orientation or even use designs of a different format?

StitchBuddy provides some important features for embroidery hobbyists:

You can open multiple embroidery files to get a preview of the design, to zoom it or

change thread colors to get an impression before actually stitching the design.

Designs can be rotated or flipped for preview. They can be printed or copied to the

clipboard and you can use their image or description in other applications.

Writing is supported for some design types to save your modifications or simply

convert embroideries from one format into the other.

In StitchBuddy's preferences you can activate a weekly check for updates and disable /

enable several warnings.

StitchBuddy is shareware, please register your copy and purchase a license code via

PayPal after testing it for your purposes.

In addition to this stand-alone application two plugins represent the StitchBuddy product

family: At the StitchBuddy website you can download a Quicklook and a Spotlight plugin

for free. Both allow you to search for embroidery designs based on their size, the number

of stitches or colors and to preview them in the Finder, Spotlight, Mail and all other

Quicklook enabled applications.

Related Topics

Change thread colors

Convert a design

Obtain and enter a license code
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Viewing embroideries

StitchBuddy can open several types of embroidery designs, currently Janome JEF and SEW,

Brother PES, Melco EXP, Tajima DST and Pfaff VP3, KSM, PCS, PCQ (binary) and PCD files.

After opening a file you see a preview of the design, the used thread colors and some

additional information: the file format and its version, the size of the embroidery, the

hoop size (only JEF, VP3 and PCS), the number of stitches and jump stitches, and the

number of color changes and different colors.

Multiple documents can be opened simultanously and you can use the "Window" menu to

navigate through them. With the "View" menu you can enable or disable 3D effects and if

jumps stitches or a grid should be displayed.

StitchBuddy is not able to write to all file formats so changes have to be discarded unless

you save the embroidery into an exportable format. The following actions can be

performed after opening an embroidery file.

Zooming: The preview of an embroidery is scaled to show the complete design. You

can zoom in/out or reset the original scaling by using the "View" menu, the

corresponding toolbar icons or enter the zoom factor directly in the toolbar. Scroll bars

are shown when zooming into a design to allow a proper navigation. These actions do

not change the embroidery file itself.

Changing colors: Colors of threads can be changed by clicking the corresponding

buttons on the right side. The Mac OS X color selector is shown and you can choose a

color in different ways: Use the color wheel to click on a color, enter its RGB

(red/green/blue) values directly or choose a color list to pick from. Several color lists

are provided with StitchBuddy, e. g. Madeira Rayon or Sulky. However you choose a

color, the most similar one of the design's current palette will be select automatically.

For more information, please refer to this chapter.

Clipboard support: You can copy a design into the clipboard to use it in other

applications. The design can be pasted as an image (TIFF or PDF) or as a textual

description, depending on the target application.

Printing: Embroidery designs including their meta data can be printed, currently with

one design per page, only. At the printing dialog box you can select if 3D effects

should be used and if jump stitches or a grid should be included.

Related Topics

Change thread colors

Convert a design
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Modifying embroideries

You can modify embroideries in several ways: Change their orientation (rotate), flip them

left-to-right or upside-down or change the color of one or more threads. While all these

changes are available to preview their effect, saving modifications is only supported for

some file formats, currently Janome JEF, Melco EXP, Tajima DST and Pfaff PCS. So be sure

to save a design into an appropriate format before performing permanent changes. Of

course you can use StitchBuddy to simply convert between file formats, i. e. save a PES

file to use it on a Janome embroidery machine.

Always check the hoop size and position of a design before actually stitching it!

StitchBuddy will remind you when saving a file, but this dialog can be dismissed for the

future. To reactivate the warnings check the corresponding option in StitchBuddy's

preferences.

Rotating: To rotate a design in 45 degree steps, just select the menu item "Design" >

"Rotate" > "Left" or "Right" or use the corresponding tool bar icons. You can enter an

angle directly with positive or negative values by choosing the menu item "Design" >

"Rotate" > "Variable..."

Rotating a design may required some major changes like switching to a larger hoop or

splitting stitches that become too long. Because of these internal modifications,

rotating a design can not be undone and a confirmation is required, which can be

dismissed for the future. To reactivate the warnings check the corresponding option in

StitchBuddy's preferences.

Flipping: To flip a design left-to-right or upside-down, just select the menu item

"Design" > "Flip" > "Left / Right" or "Up / Down" or use the corresponding tool bar

icons. This action can be undone / redone.

Center: To center a design, just select the menu item "Design" > "Center" or use the

corresponding tool bar icon. As a variable number of jump stitches is inserted to

center the design inside its hoop, center a design can not be undone. A confirmation

is required, but can be dismissed for the future. To reactivate the warnings check the

corresponding option in StitchBuddy's preferences.

Changing palettes: A design has an assigned color palette from which all thread

colors are taken. By default this is the internal palette of an embroidery file, Janone

thread colors for JEF and SEW, Brother thread colors for PES et cetera. You can assign a

different color palette, e. g. Madeira Polyneon and StitchBuddy will map all internal

colors to the most similar ones automatically. For more information, please refer to

this chapter.

Changing colors: Colors of threads can be changed by clicking the corresponding

buttons on the right side. The Mac OS X color selector is shown and you can choose a

color in different ways: Use the color wheel to click on a color, enter its RGB

(red/green/blue) values directly or choose a color list to pick from. Several color lists

are provided with StitchBuddy, e. g. Madeira Rayon or Sulky. However you choose a

color, the most similar one of the design's current palette will be select automatically.

For more information, please refer to this chapter.
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! Converting: StitchBuddy is able to export some file formats (currently JEF, EXP, DST

and PCS). Of course this feature can be used to save modifications, like color changes,

rotations or flipping. Additional you can use this function to convert emboideries

between different formats. StitchBuddy will perform some tasks to ensure a proper

conversion: Internal colors are adjusted because a different palette has to be used (JEF

only), and stitches may be splitted to meet limitations of the target file type.

Always make backups before changing your embroidery files!.

Related Topics

Change thread colors

Convert a design
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Purchasing "StitchBuddy"

Feel free to test StitchBuddy: The trial period is not limited, neither is the time, the

number of application launches nor the available functions (an unregistered copy of

StitchBuddy shows a reminder when the application starts).

Anyway, if you find that StitchBuddy suits your needs (and I am sure that you will), please

purchase an individual license. With this license you can use StitchBuddy on one or more

computers, but you are not allowed to provide the license code or a registered version of

StitchBuddy to other users.

Related Topics

Obtain and enter a license code

Start
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Change thread colors

Each design type (except Melco EXP, Tajima DST or Pfaff KSM) has its own internal palette

of thread colors, e. g. JEF uses Janome thread colors. To support other thread cards

StitchBuddy can save extended color information for every embroidery in a separate file

with the extension ".threads". With these files even Melco EXP, Tajima DST or Pfaff KSM

designs can be colorized and even better: Both StitchBuddy plugins handle these thread

files to preview embroideries properly or use their meta data.

You can change the whole palette of a design or individual thread colors. StitchBuddy will

choose the most similar color of the current palette automatically. When saving a design

in a different format StitchBuddy maps to the most similar internal colors, but if a thread

file is used the preview will remain unchanged.

To change a thread palette / a thread color:

Change the design's color palette with the menu item "Design" > "Thread File".

By default StitchBuddy will adjust every new color to match the current palette.

If you don't want this color matching, select "Individual Colors" and every color

stays exactly as selected. A ".thread" file will be written at the same location

when saving the design. Because individual colors lack a specific name, only

their RGB values will be shown.

Choose "Discard Thread File" to use original colors of a design: The internal

color palette (JEF, PES), RGB colors (VP3, PCS) or no colors at all (EXP, DST,

KSM). The current ".thread" file which holds extended color information is

deleted when saving the design. As this action effects other embroideries with

the same name (there's only only one ".threads" file for all these designs) a

confirmation is required, which can be dismissed for the future. To reactivate

the warnings check the corresponding option in StitchBuddy's preferences.

Select any other menu item and selected colors will be adjusted to the most

similars of the given palette. A ".thread" file will be written at the same location

when saving the design.

The menu item of the current palette is checked and the palette mentioned

above the thread colors, indicating wether it's external or internal. When

changing the thread palette StitchBuddy changes all colors to the most similar

ones of the new palette. As color matching is not easy to achieve you might

want to modify this guess: Please proceed with the next step.

To change a thread color click on the color well next to the color's name. The

color selector of Mac OS X is shown and you can use several ways to choose a

new color: With the color wheel you can click directly on the desired color, on

the RGB panel you can specify the red/green/blue values of a color, or you can

use color lists to pick from.

Start
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Some major color lists of embroidery threads are provided with StitchBuddy,

but please be aware that the displayed color of a thread may vary between

different applications. These color lists support searching and it is even

possible to create your own list with your favourite colors. The most convenient

way is to use the same color list as the design's palette, but that's not

mandatory.

To change the next color it is not required to close the color picker: You can

just click on the next color well without closing the selection window.

Remember: StitchBuddy will always pick the most similar color of the current

palette (if you haven't chosen "Individual Colors" in the step before).

All color changes can be undone / redone using the menu item "Edit" > "Undo thread file

change" / "Redo thread file change" or "Undo color change" / "Redo color change". All

modifications (even the creation or deletion of ".thread" files) will become permanent

when the design is saved.

Related Topics

Viewing embroideries

Modifying embroideries
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Convert a design

StitchBuddy can export to some embroidery file formats. This action requires several

internal modifications: The color palette has to be changed and StitchBuddy tries to map

original colors to the most similar new ones (except for Melco EXP or Tajima DST files).

Additionally the embroidery might contain stitches too long for the target design type, so

these stitches will be split.

To convert a design:

Open the design.

Select the menu item "File" > "Save As", change the target file name and

location as appropriate and select the target type, e. g. "Janome JEF". The file

extension is automatically chosen based on the target file type. After you have

confirmed the save dialog StitchBuddy changes the design type, identifies the

appropriate hoop size (JEF and PCS only), maps all internal colors and may split

stitches. Afterwards the file is saved.

If you have chosen an external color palette the preview will remain unchanged

as the displayed colors are stored in the ".threads" file and only the internal

colors have been adjusted. Without an external thread file the internal colors

are displayed and you might want to adjust the automatically assigned colors.

Save the file ("File" > "Save as") using the suggested file name or entering a

different one. The file name extension is selected corresponding to the design

type.

Saving a design will empty the Undo list, so previous actions can not be undone.

Nevertheless the original file stays unchanged when converting a design.

Related Topics

Viewing embroideries

Modifying embroideries
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Obtain and enter a license code

StitchBuddy is shareware. You can test the application and all its functions without

limitations, except the reminder after starting the program. Anyway, I spent a lot of time

and efforts to build this application and while the Quicklook and Spotlight plugins will

remain free, StitchBuddy costs a small license fee.

If you find StitchBuddy helpful, please purchase a personal license and support its

development. With this license you can use StitchBuddy on one or more computers, but

you are not allowed to provide the license code or a registered version of StitchBuddy to

other users.

To register StitchBuddy:

Select the menu item "StitchBuddy" > "Purchase" or click on the "Buy now"

button of the reminder at program start. Your web browser is directed to a

corresponding PayPal page and you can easily obtain a single-user license.

You can purchase a license without using StitchBuddy by simply sending the

license fee via PayPal to register@stitchbuddy.de.

After receiving your payment I will send you an email with your registration

name and license key. Please keep this mail as you might need it in the future,

e. g. after installing StitchBuddy on a different computer. Select the menu item

"StitchBuddy" > "Preferences" and enter the registration name and the received

license code under the tab "License". In the future StitchBuddy will start without

a splash screen.

If you do not want to purchase via PayPal, just sent an email to register@stitchbuddy.de

and I am sure we will find a solution.

Thank you for purchasing StitchBuddy and supporting its development and future

enhancements!
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